Solved

vlan down on cisco 3750

Posted on 2011-02-19
19
2,534 Views
Last Modified: 2012-05-11
hello experts,

i am trying to get a hp procurve switch to play nice with a cisco 3750x stack.

here is the problem: vlan21 is down, line protocol is down (what i am seeing on the cisco's).

traffic that is going to my remote subnet (192.168.21.x) is not directly connected, so i am presuming that is why it shows vlan down. i can successfully ping 192.168.21.2 (the hp switch) from 192.168.21.1/192.168.0.1 (the cisco switch).

i had to add a route on the cisco to force all traffic going to the 21.x subnet to go to the hp switch:
ip route 192.168.21.0 255.255.255.0 192.168.0.2

here are some pertinent points to the config (also wanted to mention that there is a lacp trunk between the cisco and hp switch)
interface port-channel21
 switchport access vlan 1
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 1
 switchport trunk allowed vlan 1,11,21
switchport mode trunk

interface g1/0/1 & g2/0/1
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,11,21
 switchport mode trunk
 channel-protocol lacp
 channel-group 21 mode active

interface vlan1
ip address 192.168.0.1
interface vlan11
ip address 192.168.11.1
interface vlan21
ip address 192.168.21.1

so, how do i get vlan21 up without it being directly connected?

i am also attaching a image to hopefully help clarify.

thanks, let me know if you need more information! layout
0
Comment
Question by:Jeffery Byers
  • 9
  • 9
19 Comments
 
LVL 6

Expert Comment

by:wpharaon
ID: 34935782
first this route has to be removed on the cisco switch:
no ip route 192.168.21.0 255.255.255.0 192.168.0.2
second this is not needed on the port chan interface
no switchport access vlan 1
verify that port channel is up / up and the vlan 21 is correctly created on the hp switch
0
 

Author Comment

by:Jeffery Byers
ID: 34935828
hi wpharaon,

if i remove that route, i have nothing showing in my route table how to get back to that (192.168.21.x) subnet.

i can still ping 192.168.0.2, but there is no trace of 192.168.21.1 since the vlan interface is still down/down

i did take it out to double check, and it did not fix it.

i did go back and verify that port channel is up/up and the vlan is correct on the hp switch.

any other suggestions? if i could just get this vlan up i would be set, i believe.

thanks!

0
 
LVL 6

Expert Comment

by:wpharaon
ID: 34935841
sure, since the vlan interface is in down down state it will not have a route on this subnet, however routing it by a static route is incorrect.
post us the output of:
 sh int po21 trunk
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 

Author Comment

by:Jeffery Byers
ID: 34935861
192.168.0.1-00#sh int Po21 trunk

Port        Mode             Encapsulation  Status        Native vlan
Po21        on               802.1q         trunking      1

Port        Vlans allowed on trunk
Po21        1,11,21

Port        Vlans allowed and active in management domain
Po21        1,11

Port        Vlans in spanning tree forwarding state and not pruned
Po21        1,11
192.168.0.1-00#
0
 
LVL 6

Accepted Solution

by:
wpharaon earned 500 total points
ID: 34935874
is the vlan 21 created ?
how about: show vlan
if the vlan is not existing, then create the vlan in config mode : vlan 21    then exit
0
 
LVL 6

Expert Comment

by:wpharaon
ID: 34935900
if the vlan wasn't created on the cisco, by creating it your problem should be solved,
also are you able to ping 192.168.21.2 and 192.168.21.3 from the hp switch?
0
 

Author Comment

by:Jeffery Byers
ID: 34935909
wow, you were correct, the vlan was not created (nothing under show vlan), but there was something under sh int vlan 21? strange how the interface could exist but not the vlan.

now it is up/up, but i can't ping anything on that subnet (not even the cisco itself at 192.168.21.1).

any ideas on that one?

thank you for the help
0
 
LVL 6

Expert Comment

by:wpharaon
ID: 34935912
now you need to issue no shut under the interface vlan 21
0
 
LVL 6

Expert Comment

by:wpharaon
ID: 34935914
sh ip route   output would be useful after shut/no shut for int vlan 21
0
 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 34935917
please show the HP config
0
 

Author Comment

by:Jeffery Byers
ID: 34935920
heres what i have:


192.168.0.1-00(config-vlan)#no shutdown
%VLAN 21 is not shutdown.

from the hp switch (192.168.21.2), it can ping itself and its upstream switch (192.168.21.3).

the cisco, on the other hand, is showing up on "sho vlan", is up/up for a sho int vlan 21, but still can't ping itself (192.168.21.1) or anything else in the 192.168.21.x subnet.

strange, i would have thought that would have fixed it as well
0
 
LVL 6

Expert Comment

by:wpharaon
ID: 34935921
for now it still a problem from the cisco switch side, he said he is unable to ping his own interface.
pbest93,  the static route should be removed, and then try to show us your ip routing table
0
 
LVL 6

Expert Comment

by:wpharaon
ID: 34935924
the no shutdown is needed under the interface vlan 21 and not the vlan 21
int vlan 21
 shut
 no shut
 exit
show ip route
show int vl 21
show int po21 trunk

most important is the static route for 192.168.21.0 subnet should be removed, this will be installed by connected means
0
 

Author Comment

by:Jeffery Byers
ID: 34935930
here is the hp config:


192.168.0.2# show running-config

Running configuration:

; J4903A Configuration Editor; Created on release #I.08.98

hostname "192.168.0.2"
max-vlans 24
time timezone -12
no web-management
web-management ssl
no telnet-server
interface 19
   no lacp
exit
interface 20
   no lacp
exit
trunk 19-20 Trk1 LACP
ip default-gateway 192.168.0.1
sntp server 192.168.2.2
timesync sntp
sntp unicast
snmp-server community "cilbup" Operator Unrestricted
vlan 1
   name "DEFAULT_VLAN"
   untagged 18,24,Trk1
   ip address 192.168.0.2 255.255.255.0
   no untagged 1-17,21-23
   exit
vlan 11
   name "vlan_11"
   untagged 1-14
   ip address 192.168.11.2 255.255.255.0
   ip helper-address 192.168.2.2
   tagged Trk1
   exit
vlan 21
   name "vlan_21"
   untagged 15,21
   ip address 192.168.21.2 255.255.255.0
   ip helper-address 192.168.2.2
   tagged Trk1
   exit

ip authorized-managers 192.168.11.0 255.255.255.0
spanning-tree
spanning-tree protocol-version STP
spanning-tree Trk1 priority 64
spanning-tree priority 8
ip ssh
password manager
password operator

Open in new window

0
 

Author Comment

by:Jeffery Byers
ID: 34935937
i did run the no shutdown on the interface and the vlan, didn't do the trick unfortunately.

here is the show ip route

192.168.0.1-00#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.1.2 to network 0.0.0.0

     10.0.0.0/8 is variably subnetted, 12 subnets, 2 masks
C       192.168.11.0/24 is directly connected, Vlan11
C       192.168.0.0/24 is directly connected, Vlan1
C       192.168.21.0/24 is directly connected, Vlan21
C    192.168.1.0/24 is directly connected, Vlan192
S*   0.0.0.0/0 [1/0] via 192.168.1.2
192.168.0.1-00#
0
 
LVL 6

Expert Comment

by:wpharaon
ID: 34935940
what about the output of:
show int po21 trunk

and now the 192.168.21.1 is pingable ?
0
 

Author Comment

by:Jeffery Byers
ID: 34935944
192.168.0.1-00#show int vl 21
Vlan21 is up, line protocol is up
  Hardware is EtherSVI, address is 5475.1234.5678 (bia 5475.1234.5678)
  Internet address is 192.168.21.1/24
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive not supported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:07, output 00:00:33, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     525 packets input, 53944 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     84 packets output, 6949 bytes, 0 underruns
     0 output errors, 2 interface resets
     0 output buffer failures, 0 output buffers swapped out
192.168.0.1-00#show int po21 tr
192.168.0.1-00#show int po21 trunk

Port        Mode             Encapsulation  Status        Native vlan
Po21        on               802.1q         trunking      1

Port        Vlans allowed on trunk
Po21        1,11,21

Port        Vlans allowed and active in management domain
Po21        1,11,21

Port        Vlans in spanning tree forwarding state and not pruned
Po21        1,11,21
192.168.0.1-00#
0
 

Author Comment

by:Jeffery Byers
ID: 34935956
wpharaon:tracked the non ping issue to a bad acl, that is my mistake.

appreciate the great help, i would give you more points if i could ;)

have a great night, and thanks again!
0
 

Author Closing Comment

by:Jeffery Byers
ID: 34935959
excellent answer, very quick and accurate.

thanks!
0

Featured Post

Courses: Start Training Online With Pros, Today

Brush up on the basics or master the advanced techniques required to earn essential industry certifications, with Courses. Enroll in a course and start learning today. Training topics range from Android App Dev to the Xen Virtualization Platform.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Activate recording on Zavio B7510 5M Outdoor Bullet IP camera 1 42
nexus filter logs 3 43
CISCO Smartnet agreement 5 33
Switch ports not working 8 32
In the hope of saving someone else's sanity... About a year ago we bought a Cisco 1921 router with two ADSL/VDSL EHWIC cards to load balance local network traffic over the two broadband lines we have, but we couldn't get the routing to work consi…
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

785 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question