How to fix "No Such Interface Supported" Error Message in Windows 7?

Hello,

I'm using Windows 7 Ultimate on my Dell laptop. Everything was fine and dandy until yesterday when I uninstalled a bunch of unused programs using Revo Uninstaller and Your Uninstaller. Those 2 programs were deleting registry entries left and right!

Now, whenever I select "Personalize" (by right-clicking on the desktop):

Personalize
I get this message:

Error
Would a 'Windows Repair' solve this issue? I tried Windows 'System File Checker' but it wasn't able to detect any issues.

Any help would be nice. Thanks.
rudder2Asked:
Who is Participating?
 
jcimarronConnect With a Mentor Commented:
rudder2--
"Your current version of Windows is more recent than the version you are trying to upgrade to. Windows cannot complete the upgrade."

What is the version of Windows on the installation disk you are using for the Repair Install?  Is it by any chance Win 7 whereas you have Win 7 SP1 already installed?  If so go here

http://answers.microsoft.com/en-us/windows/forum/windows_7-windows_install/i-do-not-have-windows-7-media-but-i-do-have-my/5ce13741-ac25-4969-ae82-2494726aac1c

(see Answer) to get a download of the appropriate version of Win SP 1, burn it as an .iso file on DVD and use that for the Repair Install.
0
 
EddyvanOpdorpConnect With a Mentor Commented:
Can you go back to a restore point ?
http://www.howtogeek.com/howto/11238/using-system-restore-to-recover-your-windows-7-computer/

Choose a date before you have run Revo uninstaller and Your Installer.
0
 
Joe Winograd, Fellow&MVEConnect With a Mentor DeveloperCommented:
Hi rudder2,
Eddy's suggestion is a good one. And I think the answer to your question is yes...a Windows Repair should fix it. Regards, Joe
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

 
Mark DamenERP System ManagerCommented:
I have just read that CCleaner may well be able to fix this issue,  I would suggest trying it.
0
 
JohnConnect With a Mentor Business Consultant (Owner)Commented:
Also run System File Checker as that will fix Windows components that have been damaged.

Run SFC /SCANNOW and allow to complete. Run again if errors remained from the first run. Restart the computer and check.

.... Thinkpads_User
0
 
Abduljalil Abou AlzahabInfrastructure Team Leader – Professional ServicesCommented:
Hi,
It was better to backup registry before removing any key by the application that you use, Try to boot from Windows 7 CD and do Windows Repair.

OR

This case is smeller to ur case, check it:
http://social.technet.microsoft.com/Forums/en-US/w7itproui/thread/c705bb3c-4831-4131-b5e6-a0f57313706d/
0
 
Dash AmrSenior Specialist(PM)Commented:
Follow the steps below to resolve “Explorer.exe No such interface supported” error message in Windows 7:


1. Go to start – All Programs – Accessories – Command Prompt. Right Click Command Prompt and choose Run as administrator.

Run As Administrator

2. In Command Prompt window, type in the following and press enter:
regsvr32 c:\windows\system32\actxprxy.dll

Command Prompt

Wait for the confirmation pop-up message. Try if the same error message persists. If yes, try to reboot first and check it again.

I HOPE This Will Fix - Please let us know.
0
 
rudder2Author Commented:
Thanks a lot, guys..

Eddy: Thanks. I thought of going back but I'm better off without those programs I removed :(

Joe: Thanks for the confirmation.. :)

Mark: Thanks. I tried 'scanning' and 'fixing all issues' with CCleaner, but it didn't resolve the problem.

Guess, repairing is the only option..
0
 
jcimarronConnect With a Mentor Commented:
rudder2--I do not know what you mean by Windows Repair.  If you mean Repair Install, by all means do it.
http://www.sevenforums.com/tutorials/3413-repair-install.html
It should not affect installed programs or personal data, but it never hurts to backup first.

In the future, you should be very careful what you delete from the Registry in step 4 of Revouninstaller.  I do not know enough about Your Uninstaller to comment.  I am quite negative about using CCleaner for any "cleaning of  the Registry".
0
 
Joe Winograd, Fellow&MVEConnect With a Mentor DeveloperCommented:
> Guess, repairing is the only option..

Not quite. There are still two other options:

(1) Thinkpads_user's suggestion of SFC /SCANNOW.

(2) Eddy's suggestion of going back to a restore point. I realize you said that you're better off without the programs you removed, but after going back to the restore point, you could remove them this time with the standard Windows uninstaller (Control Panel>Programs and Features) rather than Revo and Your Uninstaller, both of which are well known for removing more than they should...as likely happened in this case.

As a side comment, I stay away from products like Revo and CCleaner, as they often do more harm than good. Regards, Joe
0
 
rudder2Author Commented:
Thanks again, everyone.

@Alfa: I tried but didn't work :(

@Joe: I had tried SFC earlier and tried again now:
SFC /SCANNOW

Beginning system scan.  This process will take some time.

Beginning verification phase of system scan.
Verification 100% complete.

Windows Resource Protection did not find any integrity violations.

Open in new window


I'll be sure not to use those uninstallers and CCleaner. :(

@jcimarron: Sorry, I wasn't clear. You're right. I meant Repair Install.

Thanks for the repair install link. I have Win 7 Ultimate and am using the same disc image (mounted using PowerISO) to repair install but got stuck here:


The following issues are preventing Windows from upgrading. Cancel the upgrade, complete each task, and then restart the upgrade to continue.

Your current version of Windows is more recent than the version you are trying to upgrade to. Windows cannot complete the upgrade.


Windows needs to be restarted so necessary changes to system files can be made before continuing.


Error
Any ideas, anyone? Thanks again for your time.
0
 
JohnConnect With a Mentor Business Consultant (Owner)Commented:
At this point, the best solution (most reliable and stable) is to back up your computer (directly or boot from CD), format the hard drive and re-install Windows fresh.

.... Thinkpads_User
0
 
rudder2Author Commented:
Thanks Thinkpads_User. That's where I'm leaning to.
0
 
ded9Commented:
Did u first try new user account from control panel...the user profile might be corrupted.

Create new user account-control panel - reboot - login under the new account and check.

Reinstall is not required.


Ded9
0
 
rudder2Author Commented:
Thanks ded. I'll try that.

@jcimarron: I'm actually using Win 7 SP1 image that was used to install my existing OS. :(
0
 
Rio_10Commented:
Hi all,

I have the exact same issue with rudder2.
My difference I am in an AD invironment, and when I am logged in as standard user I get error "no such interface". When I am as AD admin all is fine.
A repair is not possible since the PC is remote.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.