Favorites folder empty in file explorer after relocating user files

Hi.  
I changed the Windows "Location" of my user files to a new drive (went from C:\Users to D:\Users)  -- Something I've done many times before.

The Links and Favorites folders were moved, but In File Explorer the Favorites folder is empty.  If I try to add something to the folder, nothing happens.   Please see screen captures attached, showing my current situation, and how it is supposed to look (from another PC).

Clearly, I missed doing something... any ideas how to fix this?
-- thanks
CaptureFavsOK.jpg
Capture-NoFavs.JPG
Rob RudloffIT Development SpecialistAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Joseph OLoughlinIT Support SpecialistCommented:
What folder are you taken to if you bring up the run dialogue with <Start>R and type in
shell:favorites
0
Rob RudloffIT Development SpecialistAuthor Commented:
shell:favorites   points to   "F:\Users\rrudloff\Favorites"

F: used to be the letter assigned to the 2nd hard drive.  That drive is now lettered D:
So, the favorites are now in "D:\Users\rrudloff\Favorites"

F:  is now a letter that Windows assinged to a USB stick that is currently in the PC
0
Joseph OLoughlinIT Support SpecialistCommented:
See
http://www.howtogeek.com/115412/change-the-default-location-for-saving-internet-explorer-favorites/
for instructions on changing the favourites folder location
The Windows7 instructions are equally applicable to Vista and Windows 8
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Rob RudloffIT Development SpecialistAuthor Commented:
That link had the answer -- I had to edit the settings in the registry, per the instructions, plus I had to edit a few other folder that still referenced "F:"    It all seem to work now.
Thanks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 8

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.