Solved

How to get EyeSpy to function with my router & port8080

Posted on 2015-02-20
26
226 Views
Last Modified: 2015-02-25
Hello Experts. I have been at this for almost two weeks. I think I am close to either a solution or getting burnt out. I have a wireless cam. I want to be able to view it from my local home net and off the internet from anywhere and on my Android. I have chosen EyeSpy software because it seems to be the most versatile app around. The camera is working fine wirelessly to my home net. However the app is telling me that in order for anything past home network to operate it must have access to port 8080.

First I spoke to the head technical person at my isp. It seems that they are ONLY interested in selling me more equipment and services. I pay $69. a month for 12 /6. I am on a wireless isp. Land based. They told me it would NEVER work unless I purchased a vlan. That would bring my monthly bill to $120. TOO much for me.

I have done my best to port forward 8080 to my computer. Then I ran an online test to see if 8080 was being forwarded and working. It said that it was working. That sounded good, however it is still not working. The app is giving the message "Could not set external port mapping via uPNP. Please configure port forwarding manually. I thought I DID accomplish that.

I don't know who to believe at this point. Why does the port 8080 check app tell me that all is well and the app is telling me that they cannot access it?  I have included some screen captures for you to look at. You can see the shot of the way I did the port forwarding.

I would truly appreciate someone that is knowledgeable about this to help me out in layman's terms. Are you up for the challenge?
2015-02-20-11-31-29.jpg
2015-02-20-11-36-32.jpg
2015-02-20-11-38-35.jpg
0
Comment
Question by:Need-a-Clue
  • 11
  • 10
  • 3
  • +1
26 Comments
 
LVL 17

Assisted Solution

by:Spartan_1337
Spartan_1337 earned 50 total points
Comment Utility
Can you try turning off the Windows Firewall? In Windows 7/8 you just have to go to the Control Panel and click on Windows Firewall. From there just turn it off (if it's on) and try again.
0
 

Author Comment

by:Need-a-Clue
Comment Utility
Hello Spartan 1337. I clicked on Windows firewall and it says that the firewall is being managed by McAfee Total Protection. I have the firewall in McAfee turned OFF for testing. Still unable to get a connection that the app is looking for. Where should I turn to now?
0
 
LVL 17

Expert Comment

by:Spartan_1337
Comment Utility
can you completely disable McAfee for testing? These AV's are very invasive and always cause problems for software that need to run on non-default ports.
0
 

Author Comment

by:Need-a-Clue
Comment Utility
Hi again. I totally removed Mcafee. It did not cure my problem. The main problem seems to be the inability for the site that needs to see my computer on port 8080. It just does not see it. I went to portquiz.net and ran their test. It says that I have reached this page on port 8080. One local "Expert" told me that even though my router says it is port forwarding that in actuality is not really doing so. I don't know if that is possible or not. Is there anything else you can think of that I might try?
0
 
LVL 26

Assisted Solution

by:Predrag Jovic
Predrag Jovic earned 150 total points
Comment Utility
Check which program is using port 8080 (many programs actually want to use it).

How to determine which program uses or blocks specific transmission control protocol ports in Windows.

And also check is port forward on router points to right host with IP address that have EyeSpy installed.
0
 
LVL 57

Expert Comment

by:giltjr
Comment Utility
What device is 192.168.1.191?
0
 

Author Comment

by:Need-a-Clue
Comment Utility
I just ran  a dos utility that shows all PIDs  At this time there are no devices at 1.191
0
 
LVL 57

Expert Comment

by:giltjr
Comment Utility
Then why are you forwarding port 8080 to that IP address?
0
 

Author Comment

by:Need-a-Clue
Comment Utility
I will be blunt. I know virtually ZERO about ddns, Ip, ports and routers. I am only responding to the experts here that are trying to assist me.  I do not understand the concept of port forwarding nor do I want to become an expert on it. I merely am seeking a solution to a problem. I bought the camera. I want the camera to function with as little grief as possible. I wish you had said: Then why are you forwarding port 8080 to that IP address? You SHOULD be forwarding it to xxxxx" I realize I am not doing "something" incorrectly. I just need to find out what is missing or what is not correct. Can you help with that?
0
 

Author Comment

by:Need-a-Clue
Comment Utility
Additional: On the ISPY main page, where the cam pix is supposed to be displayed, I see "Online (LAN only - no loopback). I am not sure if that is indicating that no loopback is a good thing or something that is missing. I went through the router and do not see an option for loopback choices.
0
 
LVL 26

Expert Comment

by:Predrag Jovic
Comment Utility
You need to setup port forward to forward ip address of your PC that have ISPY installed.
You set  PC address 192.168.1.x statically (or make dhcp reservation).
And then you set on router  to port forward port 8080 to that ip address.
0
 
LVL 57

Expert Comment

by:giltjr
Comment Utility
If EyeSpy is software running on your computer, then you should be forwarding port 8080 to the IP address of your computer, which you stated  "I have done my best to port forward 8080 to my computer.

So if EyeSpy is running on your computer, then you need to forward port 8080 to your computer.

To see if EyeSpy is up and running on your computer and listening on port 8080:

Start a command prompt window running it as Administrator.  Issue the command:

     netstat -anto | findstr /c:":8080"

You should see something like:

     TCP    0.0.0.0:8080            0.0.0.0:0              LISTENING       9999

The "9999" is the process id, so you want to see what that process is, so issue the command:

     tasklist /FI "pid eq 9999"

Is that process EyeSpy?  Also as somebody else mentioned, you may need to turn off your Windows firewall for testing.  If EyeSpy works when you turn off your firewall, then you will need to configure your Windows firewall to allow inbound requests to port 8080.
0
 
LVL 57

Expert Comment

by:giltjr
Comment Utility
Wait a second are you running iSPY or EyeSpy?
0
What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 26

Assisted Solution

by:Predrag Jovic
Predrag Jovic earned 150 total points
Comment Utility
If you set static ip on your pc as
IP address 192.178.1.50
subnet mask255.255.255.0
default gateway 192.168.1.1

Third picture should be then (with port forward settings)
eye spy 8080 8080 both 192.178.1.50 true
0
 
LVL 57

Expert Comment

by:giltjr
Comment Utility
"Online (LAN only - no loopback)." is a good thing in this instance.
0
 

Author Comment

by:Need-a-Clue
Comment Utility
The program is named ISPY.
0
 

Author Comment

by:Need-a-Clue
Comment Utility
Experts...Something possibly of aid and interesting. I disconnected completely from my router and used my cellphone with Pdanet as the isp. I then ran the Port Forwarder utility and checked to see if 8080 was available. It was not. It said Not Reachable. I would think that this test indicates that it is not something wrong with my isp or my router. I hope this helps any Expert that is inclined to continue assisting me. I DO appreciate your valuable advice.
0
 
LVL 57

Expert Comment

by:giltjr
Comment Utility
Do you still have your router setup to forward port 8080 to 192.168.1.191.  If so that it why 8080 is not available, you are forwarding to a host you say you don't have.

Your router needs to be setup to forward to the IP address of the computer you are running iSpy on.

Then you need to make sure that the computer iSpy is running either has no firewall, or that the firewall is configured to allow inbound traffic to tcp port 8080.
0
 

Author Comment

by:Need-a-Clue
Comment Utility
Hi, no, I have it forwarded to 192.168.1.50. At this point the camera IS showing up wirelessly on any network computer. However, the port 8080 is necessary if I wish to view it from a remote internet available site. As far as the firewall goes: It was/is being handled by McAfee TotalProtection. To be sure it was not the culprit I uninstalled McAfee completely. I still could not reach 8080.

Am I correct in assuming the following is correct: If I unplug my router and switch and use my cellphone as my isp, I STILL cannot get 8080. This proves it is not a router problem?? I used PdaNet on my Android and laptop to get internet access.
0
 
LVL 57

Expert Comment

by:giltjr
Comment Utility
So you changed the configuration on your router?  Because on the screen shot you originally posted you had 192.168.1.191.

Is 192.168.1.50 your computer or the camera?
0
 

Author Comment

by:Need-a-Clue
Comment Utility
That is the computer. Yes, I did change it. Due to your informative comment regarding 191 I experimented around and learned a bit. When I changed it to 1.50 it came to life. I appreciate it!
At this point I still  need the 8080 port to work somehow. Until that is working I cannot get Android usability nor internet viewing. I also experimented with various choices in the router. None of them helped so I put them back to the way I found them. Except for the 191 to 50 change.
0
 
LVL 57

Expert Comment

by:giltjr
Comment Utility
"Am I correct in assuming the following is correct: If I unplug my router and switch and use my cellphone as my isp, I STILL cannot get 8080. "

I'm not 100% sure that will work.  I've never tried to use a cell phone Internet connection for inbound traffic.  Unless your cell phone is rooted I would assume that most cell phones have a firewall enabled that blocks inbound traffic unless it is a response to a prior outbound request.  Otherwise the cell phone would be open to hack attacks.

What you can try is leaving your computer connected to your router, verifying that you have the correct public IP address, then disable wifi on your cell phone and try using your phone to access port 8080.
0
 

Author Comment

by:Need-a-Clue
Comment Utility
Ok, I will give that another try tomorrow. I use a program called PdaNet. It is free. When I use it as an isp it actually works substantially better than my normal isp. I pay for 12/6 on the normal isp. On the phone I get 15 to 20 down and 3 to 10 up. I was impressed.
0
 
LVL 57

Accepted Solution

by:
giltjr earned 300 total points
Comment Utility
I've used PdaNet in the past and it work great, but I only used it for outbound access (surfing the web , getting e-mail, ect.).  Never tired it for inbound (accessing a service I was hosting on my computer).

I don't use it now because my cell phone allows tethering and my plan includes the cost.
0
 

Author Comment

by:Need-a-Clue
Comment Utility
Just a heads-up to all that might be interested.  I paid www.portforward.com $39.95 because they guarantee to be able to forward any port you desire or your money back. They do NOT deliver even minimal service. They act like they will help, but nothing ever happens. I gave up on them and am hoping for my refund. I offered them whatever fair price they wanted for quick service. They ignored the question. I will award points now and perhaps rephrase my question in another post and hope for the best. It amazes me that this seems to be an unsolvable problem. One port???? How can that be so difficult. I have no idea. Thanks to the Experts that did try to help me. I appreciate it.
0
 
LVL 57

Expert Comment

by:giltjr
Comment Utility
I just noticed that in your original screen shot of Apps and Gaming you have another port forward for port 88.  Does that work?

Can you post the output from the command:

ipconfig /all

from the PC that you are running iSpy on.  The post another screen shot of the "Apps and Gaming" page on your router.

The only way this is difficult is if your ISP is blocking port 8080 before the traffic gets to you.
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

SSL is a very common protocol used these days when browsing the web.  The purpose is to provide security to communication, but how does it do it?  There are several pieces at work that have to be setup before SSL will even work and it requires both …
Configuring network clients can be a chore, especially if there are a large number of them or a lot of itinerant users.  DHCP dynamically manages this process, much to the relief of users and administrators alike!
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now