What is captive.apple.com and how do I stop it

In the last few days, every time I open a browser on my iPad I get a message about captive.apple.com and when I press "done" it goes away. What I want to know is how to stop it appearing in the first place.
Also every time my iPad times out and needs me to type my pin to get in, I find the wifi has disconnected (it didn't use to). To get back online I go to settings, touch the wifi connect to my router and it shows that same login screen.
I have not set this up, it's just appeared.
Another annoyance is I'm getting a webpage from my isp about setting up my broadband popping up at random if I open a new tab that links to a different page.
I suspect these things are related, so how do I stop them?
Further: my wife tells me it's happening on her iPad too, and the webpage from the isp popup also appears on the networked desktop pc while using any browser
LVL 11
speed_54Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
I am not sure what is causing your iPad to do this, but captive.apple.com comes from Akamai Technologies (23.49.87.91) which is (as far as I know) a legitimate content provider.

I would surmise you have installed something that is calling home to Akamai. But I would not expect that to disconnect your Wi-Fi.

Have you installed some dodgy content?
Dejan VasiljevicSys Admin and ProgrammerCommented:
Hi speed 54,

For the issues with iPad:

1. Turn Airplane Mode on. Go to Settings > General > Airplane Mode or to the Control Center and press the ‘Airplane’ icon.
2. Go to Settings > General > Reset
3. Press ‘Reset Network Settings’
4. Confirm reset
5. Reset your router and turn Airplane Mode off. The device should now be able to connect to the network.

That will fix Your randomly disconnections and captive site problems.

And for the webpage, can You give us a screenshot?

Thanks,
D.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
speed_54Author Commented:
@thinkpads_user nothing new has been installed.

The captive.apple problem seemingly only affects any Apple device that's connected to my wifi not android devices, so I can't see how resetting the iPad will prevent it from happening again

Will post screenshots when I can
Amazon Web Services

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

JohnBusiness Consultant (Owner)Commented:
I have checked all my Apple iPhone devices and asked family members with Apple devices and they are not afflicted in this way.

The suggestion above yours (Dejan), Item 1, serves to do a DNS Flush. Did that, or the reset help?

If not, back up your iPad with iTunes and verify it has been backed up. Then go to Settings, General, Reset and Reset All. This does a full reset after which you will need to recover from iTunes.
speed_54Author Commented:
Sorry, I haven't got back to you.
The solution by Dejan has worked on the ipads and the problem  of captive.apple and disconnecting has not recurred on them so far.
As for the webpage, that has continued to appear at random (it even came up once when i clicked the link to this question from my email notification).
Dejan VasiljevicSys Admin and ProgrammerCommented:
Hi speed 54,

I knew what is the problem with captive. And I knew it will fix Your problem with iOS based machines.

For the webpage, I think I've asked for printscreen/image if it is not a problem? So we can take a look if it is a popup, or a whole new page. Maybe if it is a page, it is set in browser to be homepage and to opens automatically when You hit new tab. It might be an add-on/extension like delta toolbar that is causing this problem(s), please send us printscreen of new tab with a problem and settings on browser itself. Because this looks like it...
So we can gather more info.

Thanks,
D.
speed_54Author Commented:
WebpageThe browser settings have not changed. The page appears on any browser ( I use safari and chrome on the iPad and ie ans chrome on the pc
Dejan VasiljevicSys Admin and ProgrammerCommented:
That could be that it is set by Your isp and it may be the part of their work. Like in Australia where You have isp that requires you to log in when you connect device to wifi or something like that. I would give em a call, and I guess they can help you with that...

Thanks,
D.
speed_54Author Commented:
Thanks heape
Dejan VasiljevicSys Admin and ProgrammerCommented:
You are welcome. I am glad that we (John and me) could help You.

Thanks,
D.
JohnBusiness Consultant (Owner)Commented:
Agreed as well. Thanks.
Ricardo AbadCommented:
Hello I have recently been having the same problem, I have tried the same thing restarting =network and router but sill no change, Every time try to go to any page it ask for username and password witch i have not set any of that. The message always pop up with captive apple ,com or the websites name with ,com at the end. Im still able to use apps with the wifi but not search for any website using the home WIFI. Pleas help
JohnBusiness Consultant (Owner)Commented:
This is an old question. I am now on iPhone SE IOS 10.1 and no issues. What IOS are you using? And, did you try resetting the Wi-Fi on your iPhone and then power all the way OFF and ON again?

If you need more help, please post a new question.
Ricardo AbadCommented:
I have IOS 10.1 as well. I did all that but I wasn't able to get ride of it. But then I got curious and went into Netgear profile and it seemed that it was out of date and when I upgraded everything it got fixed except for wifi signal disappearing once in a while.
burhani syaCommented:
Hello, all
sorry may be late
but I have the same problem that I failed to connect to wiffi because of captive.apple.com
I can handle it by logging out in the APP Store account and logging in again with the mobile network. (wiffi on disable)
then I access http://captive.aplle.com with mobile internet network until text "SUCCESS" appears.
after that i activate wiffi then login and i can return like normal
Kyle SantosQuality AssuranceCommented:
Hi sya,

I recommend asking a new question to get help from our experts.  Click the big blue Ask a question button at the top menu navigation to get started.  Good luck!

Regards,

Kyle Santos
Customer Relations
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Broadband

From novice to tech pro — start learning today.