Unable to login in webpage on lotus domino

we are trying to setup a test environment for the notes web database. when we try to login into system it do not redirect to the specified page and show "The website is unable to display the webpage " . Whereas on server we get below error:

HTTP Web Server: Function Not Implemented Exception [/names.nsf?Login] Anonymous

load internet site documents- Enabled on the server document.

what could be the possible cause ?
Kavita pawarAsked:
Who is Participating?
 
Sjef BosmanGroupware ConsultantCommented:
1st conclusion: the agent works.
2nd conclusion: the agent doesn't do what you want it to do.

Can you post the code of the agent?
0
 
Sabeel Ahmed ShakirTech LeadCommented:
Configure domcfg.nsf in domino server or create one with Domino web server configuration template from the new database creation.

Follow the below links for the same.

https://www.ibm.com/support/knowledgecenter/en/SSKTMJ_9.0.1/admin/conf_customizingthehtmlloginform_t.html

http://www-01.ibm.com/support/docview.wss?uid=swg21230037


How you are loggin in ? For example : Firstname (Space) Lastname or Firstname(dot) Lastname.

Also edit the user in names.nsf and try to set Internet password once.
1
 
Sjef BosmanGroupware ConsultantCommented:
There are many possible causes, too many in fact for me to name them all. Please tell us more about your application first, so we can narrow it down:
- how do you log in?
- is your domlog.nsf operational now? what does it contain?
- what URL did you use to open the application?
- how did you configure your website? did you use a separate website document?
- did you by any chance change the design of your Name&Address book?
- and other relevant information.

Thanks.
1
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
Kavita pawarAuthor Commented:
@Sabeel Ahmed Shakir and @ Sjef Bosman: Thank you

Yes, we did created a domcfg.nsf on test server. We are allowed to logging but it is not redirected to desired page. We have also signed all the designed elements, agents and script library with test server id. Only blank page is visible with URL containing webagent?openagent. If we remove webagent?openagent and again refresh then the desired web page is displayed with username as expected.
So now still we have a issue with redirection after login, even though all the agents, script library , design elements are signed with test server id.

Answers for the above questions
1. how do you log in?
---we login from the customized login page by username and password.

2. is your domlog.nsf operational now? what does it contain?
---No domlog is not operational.

3. what URL did you use to open the application?
---ipaddress/database.nsf

4. how did you configure your website? did you use a separate website document?
---Nope. we did not have a website document in web tab on the server

5.  did you by any chance change the design of your Name&Address book?
---Nope.

Regards
0
 
Sjef BosmanGroupware ConsultantCommented:
In your other question you said that domlog is operational... You absolutely need to enable logging! It can be set in the Server document, enable domlog. It should activate itself, if not you may have to restart the HTTP task.

We still get information from you that is hard to understand. Please put yourself in our position: we don't see your screen, we don't have your mouse or keyborad, so all we have to work with is the info you supply.

What's strange: you say
load internet site documents- Enabled on the server document.
but you also say
Nope. we did not have a website document in web tab on the server
. That's not correct. If you enable website documents, you have to add one for your website, and then you have to open the website by its domain name and not the ip-address (unless you configure the website document as a default website).

Did you try with ip-address?database.nsf?OpenDatabase&login
1
 
Kavita pawarAuthor Commented:
@Sjef Bosman : Apologies for wrong information.

Correct is load internet site documents - Disabled on the server document.

Yes we tried with ip-address?database.nsf?OpenDatabase&login .
It still display blank page with following Url
http://ip/database.nsf/WebLog?OpenAgent
0
 
Sjef BosmanGroupware ConsultantCommented:
PLEEEEEEEEASE activate domlog.nsf, and look there. Every URL is logged there, with a status, and more info.

Please report back with the details.
1
 
Kavita pawarAuthor Commented:
we activated domlog.nsf. when we hit the url after entering userid and password, It still display blank page with following Url
http://ip/database.nsf/WebLog?OpenAgent

DOmlog show stauts as : 200 OK (Request fulfilled)


Regards
0
 
Sjef BosmanGroupware ConsultantCommented:
No code??
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.